0

IPv6 prefix delegation unter Cisco IOS

Guten Tag zusammen,

nachdem ich mich vor einiger Zeit für den IPv6 Pilottest von NetCologne angemeldet habe, hat mich vor kurzem der Ehrgeiz gepackt diesen Zugang nicht nur auf meinem kleinen SOHO Router zu testen, sondern auch einmal auf richtigem Equipment.

Meine ASA 5505 kam leider nicht in Frage, da natives IPv6 mit prefix delegation nicht unterstützt wird. Ich könnte lediglich der ASA eine Adresse auf dem externen Interface zuweisen, was mich jedoch nicht weiterbringen würde, da es bei IPv6 kein NAT overload gibt.

Neben der ASA besitze ich auch noch ein paar Router. Für den Test in Frage gekommen sind ein Cisco 1841 und ein Cisco 876.

Aufgrund der geringeren Lautstärke habe ich mich dann für den Cisco 876 entschieden. Dieser verhält sich im Gegensatz zum 1841 wie ein Multilayerswitch. Somit habe ich die Konfiguration nicht auf den physikalischen Interfaces, sondern auf SVIs durchgeführt.

 

Zunächst muss auf dem Gerät das Routing für IPv6 aktiviert werden. Dies bewerkstelligt der folgende Befehl:

ipv6 unicast-routing

 

Anschließend kann der Dialer konfiguriert werden. Da ich IPv4 und IPv6 im Dual Stack betreiben möchte finden sich hier auch die bekannten IPv4 Befehle.

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

 

ipv6 address autoconfig default

Hierdurch erhält das Interface „Dialer1“ eine IPv6 Adresse.

 

ipv6 dhcp client pd prefix-from-provider

Der Router ruft beim Provider ein Präfix ab, das er später intern deligieren darf. Dieses wird in der Variablen „prefix-from-provider“ gespeichert.

 

ppp authentication pap callin

ppp pap sent-username ********@netcologne.de password ********

ppp ipcp dns request

 

Das Interface “Dialer1” wird nun auf das SVI “Vlan2” gebunden.

interface Vlan2

no ip address

pppoe enable group global

pppoe-client dial-pool-number 1

 

Dieses muss dann entsprechend wieder auf ein physikalisches Interface gebunden werden:

interface FastEthernet0

switchport access vlan 2

 

Nun müssen wir uns noch dem internen Interface des Routers widmen:

interface Vlan1

ip address 10.25.3.254 255.255.255.0

ip nat inside

ip virtual-reassembly

 

ipv6 address prefix-from-provider ::1/64

Hierdurch erhält der Router die Interface ID „1“ im delegierten Subnetz. Zudem sendet der Router nun RAs, die dafür sorgen, dass sich andere Systeme stateless mit IPv6 Adressen versorgen können.

 

ipv6 enable

 

Bitte beachten Sie, dass ich in diesem Artikel ausschließlich auf die für die Konfiguration von IPv6 über PPPoE mit prefix delegation eingegangen bin. Selbstverständlich müssen auf dem Router auch die übliche Grundkonfiguration und entsprechende Zugangsdaten, ACLs und NAT Mappings gesetzt werden.

 

Bei eventuellen Fragen stehe ich Ihnen gerne zur Verfügung.

 

Ich wünsche Ihnen einen guten Rutsch ins neue Jahr.

 

Viele Grüße

Benedikt Wollenweber

 

 

Abgelegt unter: Netzwerk, Tutorial Tags: , , , , ,

Ähnliche Artikel

Bookmarke uns!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

© 2017 IT-Dienstleistungen. All rights reserved. XHTML / CSS Valid.